USB Hardware Key Issues

Description

Loftware LabelClosed A label is a design area on the computer screen where a label format is created or edited. Manager opens in Demo Mode, but I have a USB hardware key. The key is plugged into the computer running the Loftware Label manager or Loftware Print server.
The USB Key Not Detected.

Cause

There are several potential causes of a key not being detected.

  • The Key has failed
  • There is an issue with the Sentinel Driver
  • The USB port has failed
  • The USB port is underpowered - This may happen if the LPS or LLM is installed on a laptop or notebook computer.

Solution

Use the following procedures to determine the cause of the key failure.

Key Failure

Verify that the green LED light on the USB key is lit. If the key is not lit try moving the key to another USB port, or another computer with a working LPS or LLM.

Sentinel Driver Issue

  1. Download the latest Sentinel Driver from https://supportportal.gemalto.com/csm/?id=kb_article&sys_id=e88691ba37edcb08cc47261953990e80
  2. Install the driver. In some cases the install will give the option to run a repair or upgrade depending on the existing version of the driver in use.
    Note: A copy of the Sentinel Driver can also be found in the Loftware Labeling root Directory, DIAGNOST\Sentinel folder.

  3. Retest the key after installing the driver.

Sentinel Utility

You can download the AdvancedMedic utility from the SafeNet website.
The utility can create a log file that you can send to SafeNet support for further analysis.
{+}http://www2.safenet-inc.com/support/enduserform.asp+

SafeNet Sentinetl AdvancedMedic Window
Sample Log file created by the Safenet Sentinel AdvancedMedic
*********************************************************************SafeNet Inc. :: Sentinel Keys Diagnostic Tool V 1.3*********************************************************************Log File Version : 1.3.1Start Date : Fri Jun 22 19:24:17 2011End Date : Fri Jun 22 19:24:17 2011KEY MODULE : 1.3 Fri Jun 22 19:24:17 2011DRIVER FILE :SNTNLUSB.SYS PresentFile Size is 38376 bytesCurrent Driver VERSION : 7.5.7DRIVER LOADED : SafeNet USB SuperPro/UltraProDRIVER FILE : SENTINEL.SYS PresentFile Size is 92712 bytesCurrent Driver VERSION : 7.5.7DRIVER LOADED : SafeNet USB SuperPro/UltraProSERVICE PRESENT : Sentinel Protection ServerSERVICE STATUS : The service is running.SERVICE PRESENT : Sentinel Keys ServerSERVICE STATUS : The service is running.KEY STATUS : SuperPro Key PresentDeveloper ID of the key : 79e4
SYSTEM MODULE : 1.3 Fri Jun 22 14:27:42 2012Pinging : 172.16.35.254
Ping to Gateway is successfulPing Time : 0
Pinging : localhostPing to IPaddress is successfulPing Time : 0 ms
FireWall Status : OFF
Sentinel Protection Server Not Present
Sentinel Keys Server Not Present
 

Failed USB Port

  1. Open Computer Management or Device Management from the server with LPS or LLM installed.
  2. Select Universal Serial Bus Controllers from the Device Manager Tree.
  3. There may be an indication on the General tab if there is an issue with the controller.
    Note: You can use the Properties window to view which driver version you are using.

    Device Manager with SafeNet USB Properties Window
     

Underpowered USB Port

In some cases the USB port being used does not supply enough power for the system to detect the key.
Plug the key into a desktop computer.

Note: Avoid ports in keyboards, monitors or other computer accessories. Plug the key directly into a port on the computer or server is possible.
If the key is detected, there is a possibility that the port is under powered.